I get ‘Your browser is not supported’ message
If you see an "Unfortunately your browser is not supported" error message, please switch to a recent, desktop version of Google Chrome, Firefox, Opera, or Safari. If the error is still present, please, contact our support team.
The error message

Details

The Account page uses Web Worker and Web Crypto APIs when a user authenticates and performs security actions like enabling 2FA or approving access to the shared data. These APIs are required to proceed yet can be unavailable or have implementation errors in old browser versions.
Check out the security overview page for details on the authentication process.
Last modified 7mo ago
Copy link
Contents
Details